An error occurred while reseting engine.

1
0
-1

I wanted to change the default H2 database to MySQL database, so I followed this instruction .
After configuring the properties files, I used command line to start-bonita.bat, and I have some error messages like this one.

2017-02-07 14:20:00.396 -0500 SEVERE: org.apache.catalina.core.StandardService Failed to initialize connector [Connector[HTTP/1.1-8080]]
org.apache.catalina.LifecycleException: Failed to initialize component [Connector[HTTP/1.1-8080]]

And in the Bonita BPM Studio, I am no longer able to publish Organization or Reset engine and when I try it gives me this error message.

An error occurred while reseting engine.

Run has failed while undeploying the process
com.sun.proxy.$Proxy43.login(Unknown Source)
org.bonitasoft.studio.engine.BOSEngineManager.loginTenant(BOSEngineManager.java:294)
org.bonitasoft.studio.engine.BOSEngineManager.loginDefaultTenant(BOSEngineManager.java:274)
org.bonitasoft.studio.engine.operation.UndeployProcessOperation.undeployAll(UndeployProcessOperation.java:117)
org.bonitasoft.studio.engine.operation.UndeployProcessOperation.run(UndeployProcessOperation.java:92)
org.bonitasoft.studio.engine.command.ResetEngineCommand$1.run(ResetEngineCommand.java:51)
org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:122)

Now, if I connect to the portal manually by typing "http://localhost:8080/bonita", it's the HTTP Status 404 page.
What could be the problem, what would I be missing, and How can I fix these errors?

1 answer

1
+1
-1
This one is the BEST answer!

This may not be the answer you want to hear but changing the database of Studio is CURRENTLY NOT POSSIBLE. The documentation should say this but it doesn't.

This is a recurring problem with people trying to do it so I've created a bug report about the documentation to have it fixed.
https://bonita.atlassian.net/browse/BBPMC-456

regards
Seán

PS: While you may not like the answer, it gives the correct answer, please mark as resolved.

Comments

Submitted by zibek8 on Wed, 02/08/2017 - 15:11

I see. Thank you for your quick answer. I would have spent another day just to trying to fix this error.

Testing
Notifications