Add special characters in file


Im having trouble to configure my database password which have special characters, for example "Pa$$word".
In the I tried the following configuration:
db.password=Pa$$word but when I tried to start tomcat and exception ocurred, then I decided to escape the specials characters like so:
db.password=Pa\$\$word this time I received an access denied exception.

I know my problem is with the special characters because when I changed the db connection password to Password and configured the I could start tomcat without any problem.

So can you guys tell me how can I add special characters to the file?

Im using Bonita 7.5.4,



Submitted by Sean McP on Tue, 08/08/2017 - 18:42

Why restrict yourself to 8 digits passwords they are known to be easy to break.

Why not use passphases as all security personnel are now recommending. Something that is 16 letters long is much harder to crack than 8 digits with special characters.

Submitted by mzhu on Wed, 08/09/2017 - 17:03

The 8 digits password was just and example, about the specials characters, well its part of the business policy is not something that I can change easily.

Didn´t hear about passphrases before, ill keep that in mind for the future, thanks for you suggestion.

2 answers

This one is the BEST answer!

After more research I found out what cause the issue.

The setup tool use the values in to replace tokens defined in bonita.xml file (located in setup/tomcat-templates). In order to perform this search and replace it use replaceAll method that give special meaning to the $ and \ character in the replacement string.

I report the issue and here is a temporary workaround: simply edit the bonita.xml file located in setup/tomcat-templates and manually replace @@ds1.database_connection_password@@ and @@ds1.database_connection_password@@ with your password.


Submitted by mzhu on Wed, 08/09/2017 - 16:58

Interesting, after following your instructions and manually replace the password in bonita.xml, in the end I had to replace the password in that is in the same directory and I had to do it too in the file inside of the setup directory.

After doing that I could launch the portal, thanks for your help.


Can you try to escape the $ character by using #{'$'} instead?


Submitted by mzhu on Tue, 08/08/2017 - 15:52

Thanks for your answer antoine, I configured the file with:
But didn´t work :(, got the acces denied exception again.