Application page not found

1
0
-1

Hi everyone,

Me and my team are facing a strange behavior in Bonita Studio Community 2021.1

image.png

Suddenly, some of our application pages are not found during a deployment.
This is happening only to some of us, while other coworkers can deploy the application without any problem.

In our Application descriptor file the orphan pages are correctly named:

image-1.png

The screenshots above are taken after a re-installation of Bonita Studio, right after importing the project via the Git plugin. Before re-installing Bonita what I (personally, on Linux) tried to do was deleting the

~/.cache/Bonita\ Studio/

directory.

Another hint on what is happening is how only the directories of the incriminated pages are named inside "workspace/tomcat/server/temp/bonita_portal_5399@host/tenants/1/pages/" :

  • p8102719433436223374_custompage_strategyDefinitionPage
  • p8102719433436223374_custompage_proposalPage
  • p8102719433436223374_custompage_proposalApproval
  • custompage_dashboard
  • custompage_portalPage
  • p8102719433436223374_custompage_exposureAnalysis

As you can see, the directories of the pages that are not found are created using a prefix in front of their name, and I suppose that's the cause of the "not found" problem.

What we tried to do:

  • re-installing Bonita Studio
  • re-cloning the project via the Git plugin
  • re-starting the server from inside Bonita Studio
  • deleting the cache of Bonita Studio (on Linux)
  • yes, restarting the computer

As said before, we are collaborating using Git and the problem occurs both on Windows and on Linux.
Previously the problem occurred on a smaller selection of the pages, but we fixed it restarting the web server or reinstalling Bonita Studio.

The only solution to this problem seems to be renaming the problematic pages: changing the name of the pages from the Ui Designer (and updating accordingly the application descriptor) solves the problem! But it is not a very convenient solution when a lot of people work on the project. Also, it is not a solution to the problem, just a way to work around it.

Thanks in advance.

No answers yet.
Notifications