Bonita BPM stop working or not response and Disk Queque Length


Currently identified situation.
When there was an attempt to create the “internal correspondence” process at the same time, the Bitronix logs prescribed a timeout, but in fact Postgres worked, and the monitoring increased the length of the disk queue (the delay was up to 10 ms).
After 1-2 minutes, the process worked as usual and I managed to create 10 processes.

During the timeout, other processes, including service.

I ask you to correct this error.

Bonita 7.8.4(RAM 4 gb used)
Postgres 10 (RAM 2 gb used)
Windows MS 2016 Standart
Proc Xeon 2.4 G
RAM 8 gb
HDD 60 gb
users bonita 100
all processes 25 000
active processes 200
active tasks 200


1 answer

This one is the BEST answer!

Antoine Mottier on

14 января 2020 г., 10:43

Can you try to update to the latest version of Bonita available (currently 7.10.0) and see if you still reproduce the issue?

Since version 7.9.0 Bonita use a different transaction manager (Arjuna) and several improvement related to Engine performance has been done so there is a chance that the issue is now fixed.

---my comment

As it turned out, postgres settings were in some places at the default level. We used pgtune and were able to improve the performance of Bonita - it would be nice if you added a link to pgtune to the performance article.
We also upgraded the version of Bonit and Postgres to the latest versions, and also separated the database from the application.
After that, everything began to work great.