Can somebody explain me what I have to do to make a database connection work? Get a exception and i have no idea how to fix it.


I'm pretty new to Bonita bpm.
At the moment I'm experimenting with it, and try to discover the capabilities of it. (because it could be interesting for our research institute)
I created my first lane with a simple process, and now I want to make a database connection to my Orcale 11g Express edition database.

So I added a connector(ojdbc7.jar as db driver) with a working db URL. (tried it with the SQL Developer)
In the database access information window I have this at the driver field:
and my URL:
and the user information.

The query is this:
select * from getraenke

Now, if I try the connector out, I get this exception:

org.bonitasoft.engine.bpm.connector.ConnectorExecutionException: USERNAME=install | org.bonitasoft.engine.core.connector.exception.SConnectorException: org.bonitasoft.engine.connector.exception.SConnectorException: java.util.concurrent.ExecutionException: org.bonitasoft.engine.connector.exception.SConnectorException: org.bonitasoft.engine.connector.ConnectorException: java.lang.SecurityException: Package was already sealed with another URL: package=oracle.jdbc.driver, url=file:/home/kraemm/BonitaBPMCommunity-7.1.3/workspace/tomcat/bonita/engine-server/work/platform/bonita_engine_17562@zitpcx17328/local/PROCESS/8637592303074397449/8637592303074397449_ojdbc7.jar.jar4627430663138202486.tmp

and I have no idea what this mean nor what I have to do?!
(nobody in our IT section has any experience with Bonita yet )

If somebody can help me, I would appreciate this.


Btw,: I use Ubuntu 14.04 and have the latest bonita bpm version.
I use the ojdcb7 driver.

Okay, I did this:

And that seems to be the problem. I reinstalled Bonita and tomcat was running.
After I followed these steps for a Orcale connection, it did not work anymore.

I always get the error message, that Tomcat maybe is running in a other instance, so it cant be started.
I cant even acces to the default localhost page.

I have no idea what Im doing wrong.


Submitted by Sean McP on Thu, 12/03/2015 - 15:42

where did you put the jar?

It has to go into %Bonitasoftroot%\workspace\tomcat\lib

Submitted by Sean McP on Thu, 12/03/2015 - 15:45

Then again having just read a couple of posts, maybe you should remove it completely and see what happens...


Submitted by m.kraemer85 on Thu, 12/03/2015 - 17:37

Hi, the jar is in the workspace\tomcat\lib.
But I found something strange.
I used the bonita installer for the installation and now I have 2 tomcat folder?!
One is in the plugins folder of the bonita directory.
Do anybody know why?

And I cant answer until monday, because of a family emergency. Have to travel to my hometown for some days.
Thanks for the help.

3 answers



My usual workaround is to remove the file jdbc.jar from the .bar file (it's just a zipped file) before installing the process in the server.

Hope it helps,


i understand, I needed Teradata, but I started with mysql which runs local.


I am new too so I started with something that worked end to end.
That gave me confidence to change things bit by bit.

My 2 cents is for you to try it with mysql running localhost (instead of jumping into oracle right away).
youtube link


Submitted by m.kraemer85 on Thu, 12/03/2015 - 17:31

Hi, the problem is, that we work with a oracle db.
So it would be usefull to get a oracle thing to work ;-)

Submitted by gpscruise on Tue, 10/25/2016 - 16:41

agreed, I needed teradata, but I stared with mysql-localhost to learn first.