Error while starting the case - no logs, no explanation

1
0
-1

Hi,

Have been a user of Bonitasoft for years, but this is the first time coming across this issue. Users have been getting a message [Error while starting the case] when trying to submit a case from the instantiation form.

What's unusual is that it happens inconsistently, and there are no logs written when it happens. No errors reported, nothing in the log files, and no debug messages on the form itself. Additionally, some users have been able to "resolve" it by repeatedly hitting the [Submit] button. Also, it is not limited to one process; we have four processes available to users on portal and all four have suffered this issue.

The setup is Bonitasoft 7.11.1 Community running with MySQL on a linux server. Any help or advice on where to look to resolve this would be greatly appreciated

Comments

Submitted by Dibyajit.Roy on Sun, 01/10/2021 - 15:38

Hello
change Log level to capture the complete Logs.
look for /server/conf -> logging -> change the org.hibernate.level and see if the log file captures more details or not.
There is also another log to capture error logs from browser (not engine error logs ).

Regards

Submitted by greg.oxley on Sun, 01/10/2021 - 15:59

Hi Roy,
We've since done that thank you and are waiting for users to generate more logs to read. With regards to the browser logs, that may be difficult to get without asking users to have their browsers' consoles open at all times

1 answer

1
0
-1

Hello,

That's happening in general where the contract is not respected. Then, you don't have any logs.

Did you capture this error to give it back to the user (use the DisplayFailed Widget in your page)?

Else, do a F12 and see the payload.

Best,

Notifications