[Help] Bonita won't start "Run" or "Portal"

1
0
-1

Hello Bonita-Community,

I face one serious problem: Whenever i want to execute or "Run" a diagram, this happens: What I know this Diagram is a new one and kind of blank. But i've tried to reinstall Bonita for at least 20 times on different HDDs, SSDs, also USB sticks.

I've deleted every registry-entry in Windows' "regedit" and rebootet several times.

I've also reinstalled every web browser (Firefox and Chrome) i have on my pc.

The only solution I got so far is using another Windows User Account on the same pc.

BUT this does not help me at all! I need my personal account!

Please help! What is this??

PS: It worked yesterday!!!

Comments

Submitted by bos2013 on Tue, 11/25/2014 - 13:56

Hello,

Could you please just tell us which version are you using ? And if you have any logged information on the STUDIO logs and Engine Logs ?

Then if it works with another user account, have you checked the user rights to execute it ?

What is the version of java and windows installed on your personal account ?

Regards,

Submitted by Gseth on Tue, 11/25/2014 - 14:05

Greetings bos2013,

I use Bonita 6.3.8 Community.

Studio Log

  1. !ENTRY org.bonitasoft.studio.engine 1 0 2014-11-25 13:41:12.788
  2. !INFO bonita_journal.db.h2.db has been deleted successfuly
  3. !SESSION 2014-11-25 14:03:18.348 -----------------------------------------------
  4. eclipse.buildId=6.3.8.
  5. java.version=1.7.0_55
  6. java.vendor=Oracle Corporation
  7. BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=de
  8. Framework arguments: --launcher.XXMaxPermSize512m -groovy.compiler.level 18 -clearPersistedState
  9. Command-line arguments: -os win32 -ws win32 -arch x86 --launcher.XXMaxPermSize512m -groovy.compiler.level 18 -clearPersistedState
  10.  
  11. !ENTRY org.bonitasoft.studio.application 1 0 2014-11-25 14:03:29.002
  12. !INFO Startup duration : 00:00:09
  13.  
  14. !ENTRY org.bonitasoft.studio.actors 1 0 2014-11-25 14:03:40.084
  15. !INFO Loading organization ACME in portal...
  16.  
  17. !ENTRY org.bonitasoft.studio.engine 1 0 2014-11-25 14:03:41.177
  18. !INFO Building bar for process Pool1 (1.0 )...
  19.  
  20. !ENTRY org.bonitasoft.studio.engine 1 0 2014-11-25 14:03:41.764
  21. !INFO Build complete for process Pool1 (1.0 ).

Engine Log

  1. 2014-11-25 14:03:38 org.apache.catalina.core.ContainerBase.[Catalina].[localhost].[/bonita]
  2. FEIN: Starting filter 'RestAPIAuthorizationFilter'
  3. 2014-11-25 14:03:38 org.apache.catalina.core.ContainerBase.[Catalina].[localhost].[/bonita]
  4. FEIN: Starting filter 'BPMURLSupportFilter'
  5. 2014-11-25 14:03:39 org.bonitasoft.console.server.listener.StudioWatchdogListener
  6. WARNUNG: Bonita Studio watchdog process has started on 6969 with a delay of 20000ms
  7. 2014-11-25 14:03:42 org.bonitasoft.engine.api.impl.ProcessAPIImpl
  8. INFORMATION: THREAD_ID=41 | HOSTNAME=Generic | TENANT_ID=1 | The user <walter.bates> has installed process <Pool1> in version <1.0> with id <6367158852204051456>
  9. 2014-11-25 14:03:42 org.bonitasoft.engine.api.impl.transaction.process.EnableProcess
  10. INFORMATION: THREAD_ID=41 | HOSTNAME=Generic | TENANT_ID=1 | The user <walter.bates> has enabled process <Pool1> in version <1.0> with id <6367158852204051456>
Submitted by bos2013 on Tue, 11/25/2014 - 15:47

Hello,

There is no error in the logs. Once you started the studio, can you try to access following links (try increase the port number in case it switched to 81 or 82): http://localhost:8080/

http://localhost:8080/bonita/

This is to check if tomcat and bonita are accessible.

Finally on your PC, under directory : BonitaBPMCommunity-6.3.8\workspace\tomcat\bin - Launch shutdown.bat and then startup.ba - Check again above two links.

I don't understand your issue. It seems that based on the logs that both the ACME organization was load, and the process built (*.bar) and deployed. Then the user walter.bates has enable the process without any issue.

Have you installed the community with admin rights ? and what is the path where you installed it ? How about the firewall and co ?

A bientôt. LL

Submitted by Gseth on Tue, 11/25/2014 - 17:17

[SOLVED]

Hey,

I have solved the problem.

Bonita thought that the Windows Texteditor was my default Browser. That's why it worked on another Windows-Account, because there the default browser was IE.

You can change this in Bonita at your Web-Settings.

Thanks for your help, though!

No answers yet.
Notifications