How to access process variable in Bonita ui


I have tried simple process variable example given at link using BonitaBPMCommunity-7.3.1-Tomcat-7.0.67.Process Variable is accessible when i run process in bonita studio but when i run process in tomcat bundle then process variable is inaccessible. It is accessible only when user is administrator. How to access process variable when user is simple user but not administrator.

Error (when i run process in Mozilla Firefox developer mode):
myProcessVariable is a Process Variable defined in process.

http://localhost:8888/bonita/portal/resource/taskInstance/ProcessVariabl... [HTTP/1.1 403 Forbidden 0ms]
no element found
In Log file i got error when i submit Instantiation form.
Error evaluating < formOutput > data: $data.processVariableValue is undefinedvendor.min.js:105:441

Log File:

016-12-01 03:11:47.497 -0800 INFO: org.bonitasoft.platform.setup.PlatformSetup System property org.bonitasoft.platform.setup.folder is set to C:\BonitaBPM\BonitaBPMCommunity-7.3.1-Tomcat-7.0.67\setup
2016-12-01 03:11:47.541 -0800 INFO: org.bonitasoft.platform.setup.PlatformSetup Connected to 'h2' database with url: 'jdbc:h2:tcp://localhost:9091/bonita_journal.db' with user: 'SA'
2016-12-01 03:11:47.545 -0800 INFO: org.bonitasoft.platform.setup.ScriptExecutor configuration for Database vendor: h2
2016-12-01 03:11:47.757 -0800 INFO: org.bonitasoft.platform.setup.PlatformSetup Platform is already created. Nothing to do.
2016-12-01 03:11:47.866 -0800 INFO: org.bonitasoft.engine.EngineInitializer Initializing Bonita Engine...
2016-12-01 03:11:47.866 -0800 INFO: org.bonitasoft.engine.EngineInitializer Initializing Spring context...
2016-12-01 03:11:58.510 -0800 WARNING: org.hibernate.type.TypeFactory HHH000233: Scoping types to session factory org.hibernate.internal.SessionFactoryImpl@ac6f04 after already scoped org.hibernate.internal.SessionFactoryImpl@ac8478
2016-12-01 03:12:02.630 -0800 INFO: org.bonitasoft.engine.EngineInitializer Starting platform...
2016-12-01 03:12:10.080 -0800 INFO: org.bonitasoft.engine.EngineInitializer Platform started successfully
2016-12-01 03:12:10.081 -0800 INFO: org.bonitasoft.engine.EngineInitializer Initialization of Bonita Engine done! ( took 22215ms)
2016-12-01 03:13:41.877 -0800 INFO: org.apache.catalina.core.ContainerBase.[Catalina].[localhost].[/bonita] RestletServlet: [Restlet] ServerServlet: component class is null
2016-12-01 03:13:42.396 -0800 INFO: org.apache.catalina.core.ContainerBase.[Catalina].[localhost].[/bonita] RestletServlet: [Restlet] Attaching application: to URI: /bonita/API
2016-12-01 03:13:42.412 -0800 INFO: org.restlet.Component.BonitaRestletApplication Starting application
2016-12-01 03:15:43.466 -0800 INFO: org.restlet.Component.BonitaRestletApplication Error while validating expected inputs
Expected input [newVariableValue] is missing


Submitted by lee.chang223 on Sat, 12/03/2016 - 00:01

can any one provide guide ???

1 answer


try this one:


PS: As this reply answers your question, please mark as resolved by ticking the tick mark on the left of this reply.

Please do NOT ask repeat questions, we will answer it if we can. This is a community forum we do not get paid for this.

You asked the same question here: