How to connect postgres database

1
0
-1

In my process I am using BDM (bussiness data) bussiness object and attributes to that. I configured database.properties file with postgres . But, I am able to see only engine daabase I want to see BDM database also which I created busssiness object table and data in that table.Please help me in getting Bussiness database also. Thanks

1 answer

1
+1
-1

Hello.

In the database.properties file there should be 2 parts, one for engine database, the other one for business data database.

All properties for engine database are prefixed by db.: db.vendor, db.server.name, db.server.port and so on

All properties for business data database are prefixed by bdm.db.: bdm.db.vendor, bdm.db.server.name and so on

Did you configure both?

HTH

Comments

Submitted by ramireddy.pingala on Sun, 05/17/2020 - 15:53

Hi baptiste.mesta ,Thank you for your response. yes I configured the same as below, but still I am able to see only db.database.name=bonitaDB not the second one.Please help me

#########################################
# Bonita database properties
#########################################

# valid values are (h2, postgres, sqlserver, oracle, mysql)
db.vendor=postgres
# when using h2, no server or port setting is needed since connexion is made using file protocol mode using relative directory:
db.server.name=localhost
db.server.port=5432
# if your database name contains a backslash (\) character, you must double it (\\):
db.database.name=bonitaDB
db.user=rainbow
# if your database password contains a backslash (\) character, you must double it (\\):
db.password=XXXXXXXX

###################################
# Business Data database properties
###################################
# valid values are (h2, postgres, sqlserver, oracle, mysql)
bdm.db.vendor=postgres
bdm.db.server.name=localhost
bdm.db.server.port=5432
bdm.db.database.name=bussiness_data
bdm.db.user=rainbow
bdm.db.password=XXXXXXXX

Submitted by baptiste.mesta on Fri, 05/22/2020 - 16:02

Hello,

You should be able to access the tables of your business data by connecting to your postgres directly.

However the database is not the same as the one for bonita tables: bdm.db.database.name=bussiness_data

Notifications