Incompatiable with Chrome 60


yesterday i updated my chrome (59) to chrome 60 then Bonital BPM Portal (studio and wildfily server both ) did not work with it.
i can only read the any info but can not write any data back ,such as change user data etc.

other browsers IE and firefox work well.

i use Bonita BPM 7.5 with Wildfly.

please check it


Submitted by santhosh.teegala on Tue, 08/08/2017 - 12:22

We are also getting same issue, with chrome60 no data found in process and tasks list. We cannot pic pending task from inbox. it showing no data found in inbox. please help me if any one have an idea about this

Submitted by antoine.mottier on Tue, 08/08/2017 - 13:57

Did you try the version 7.5.4? This version fix the issue.

Submitted by santhosh.teegala on Tue, 08/08/2017 - 15:19

No antiine. We are using bonita v6.5. all our production users stopped to use chrome because of this

Submitted by antoine.mottier on Wed, 08/09/2017 - 09:42

For Community Edition you can edit the file portal/scripts/includes/common.jsthat is part of bonita web app and add the following code at the end of the file:

// Monkey Patch xhr
// Due to a specification change in the xhr.getAllResponseHeaders method Bonita Portal does not behave as expected
// in browsers that implement this new specification (currently only Chrome >60).
// This patch fixes xhr.getAllResponseHeaders unwanted behavior whithin Bonita Portal context
//    See
//    See
(function (xhr) {
    var caseSensitiveHeaders = ['Content-Range', 'X-Bonita-API-Token'];

    var getAllResponseHeaders = xhr.getAllResponseHeaders;

    xhr.getAllResponseHeaders = function () {
        var headers = getAllResponseHeaders.apply(this);
        for (var i = 0; i < caseSensitiveHeaders.length; i++) {
            headers = headers.replace(new RegExp('^' + caseSensitiveHeaders[i].toLowerCase(), 'm'), caseSensitiveHeaders[i]);
        return headers;
Submitted by santhosh.teegala on Wed, 08/09/2017 - 10:05

Thanks a lot Antoine. It is perfectly working for me. :-)

Submitted by marcos.laurito on Tue, 08/15/2017 - 15:52

I'm using Bonita 7.1.2 Community but the patch posted by antoine didn't work for me. Any more details about it?

Submitted by antoine.mottier on Wed, 08/16/2017 - 09:57


I just test the batch on the Bonita 7.1.2 Community Tomcat bundle and it seems to work just fine. Did you edit the file inside the bonita.war or in the webapps/bonita folder? You should edit it inside the bonita.war file and make sure that it get redeploy (file should be automatically updated in webapps/bonita once bonita.war is redeployed).

Submitted by marcos.laurito on Wed, 08/16/2017 - 14:25

Just made it work. Delete browser cache and it works ok!! My bad.

Submitted by Ali Zaami on Wed, 12/13/2017 - 09:58

Thank You antoine,

1 answer

This one is the BEST answer!


I can confirm the issue and I'll open a bug report.

Issue is likely to be related to the use of a non standard HTTP header in the Portal (X-Bonita-API-Token).

Issue will get a fix at latest in maintenance release next Thursday.

Update: issue is fixed in release 7.5.4.


Submitted by Sean McP on Sun, 07/30/2017 - 00:00

While I understand the need to keep maintenance releases in check, this one because it breaks functionality of the whole product, should be treated as an emergency update release and released today...

The fact that we've had to stop a number of developers and users implementing security updates (chrome) and some others simply cannot work with Bonitasoft (because they've already updated) is a real issue to us.

We can't wait for a week for a fix when some of our staff are basically made redundant because of this issue.

The issue, yes can be attributed to updating chrome, but the root cause fix is Bonitasoft's and that needs to come quicker than a week.


Submitted by antoine.mottier on Mon, 07/31/2017 - 08:53

I understand the severity of this issue and this is why I said that fix will come at latest in the next maintenance release.

In the meantime you can maybe use Firefox, Internet Explorer or Edge to keep developing your application.

Submitted by Sean McP on Tue, 08/01/2017 - 03:59

Thanks for your understanding Antoine, that's what we're doing, just wanted you to be aware of the significance of the issue.

And because we disable the use of IE and do not sanction the use of Firefox we've had to make some quick GPEDIT changes...

Anyway understood...and thanks for fixing it in short time.

Submitted by Dibyajit.Roy on Tue, 08/15/2017 - 17:12


This was officially announced by Bonitasoft.
I received a mail from Bonitasoft team about this issue.
They have a workaround for this.

check the official Bonitasoft site. There is a Link to an article to fix this issue.


Submitted by marcos.laurito on Tue, 08/15/2017 - 17:22

Hello Dibyajit, where i can find this article that you said?
I've already checked Bonitasoft site but i only see a banner saying that i should update my server to version 7.5.4 to fix the chrome problems (not possible to update for me, at least for now). I need a workaround but can't find it. I've tried the solution posted by Antoine on this same post, but doesn't work for me.

Thanks in advance.

Submitted by Dibyajit.Roy on Tue, 08/15/2017 - 17:28

could you share your Email id .
I will send you the screenshot of the message to your email directly.

Submitted by marcos.laurito on Tue, 08/15/2017 - 17:39

Sure. Thanks

Submitted by Dibyajit.Roy on Tue, 08/15/2017 - 17:35

email sent .