incompatible JVM error on brand new iMac


I have a brand new iMac, literally purchased today, and I downloaded Bonita BPM Community for a university subject. On installation of Bonita it told me that it would install it's own version of Java (1.6.0) and use this as I had not installed Java.
The install appeared to go seamlessly. However, upon trying to open the application it gives me an error message:
Incompatible JVM - Version 1.6.0_65 of the JVM is not suitable for this product. Version 1.8 of greater is required.

So I installed Java 8.0 (which is greater than 1.8 if my maths is correct) but I get the same error.

What is the actual problem here and, more importantly, how do I resolve it?

Kind regards,



Submitted by ric.hayman on Sat, 12/02/2017 - 13:40

Very similar problem - just installed 7.5.4 64bit on my MacBook Pro and had the same message (with different ‘wrong” version, but otherwise identical): “Version 1.7.0_25 of the JVM is not suitable for this product. Version 1.8 of greater is required.”
What I have installed according to the Java Control Panel is Java 1.8.0_151, and the version downloaded with Bonita is 1.8.0_112 … I haven't had v1.7* installed for a long time.

Like Matt, my question is: what IS going wrong, and how do I fix it?


Submitted by ric.hayman on Sun, 12/03/2017 - 23:51

Footnote: Macbook is running MacOS 10.13.1. High Sierra

1 answer


Can you share the output of the following commands run in a Terminal:
ls -la /System/Library/Frameworks/JavaVM.framework/Versions java -version

I recommend to uninstall Java 6. To do so run the following command in a Terminal: sudo rm -rf /System/Library/Java/JavaVirtualMachines/1.6.0.jdk sudo rm -rf /Library/Java/JavaVirtualMachines/1.6.0*.jdk

And install Oracle JDK 1.8.0 that you can get directly from Oracle.

If you are using the macOS .dmg installer of Bonita there is currently an issue preventing the Studio from using the embedded JVM (issue is fixed in upcoming 7.6.0 release).
Here is a workaround to fix the issue: after running the installer you need to locate the BonitaBPMCommunity.inifile in, edit it and remove the leading white space in front of the -vm line and JVM path line.


Submitted by ric.hayman on Tue, 12/05/2017 - 00:32

Thank you - changing the .ini file to point to the included JVM worked for me. Look forward to v7.6.0 :)