New version 2020.1 studio very slow



The Bonita Studio from the new 2020.1 Community version has become very slow, comparing to the previous one (7.11.4).

Each time I have to open a pop-up window to view or modify a script; it now takes tens of seconds. Before it was instantaneous.

It's unbearable and considerably slows down the development of processes.

Is there something to do ?

Thank you in advance for your answer.



2 answers

This one is the BEST answer!


I have downloaded the new version and now it works fine !

Thank you.



Hi Thierry,

Thank you for the feedback. What OS are you using? Is there anything in the Studio logs?




Submitted by kurucsai.zoltan... on Thu, 02/11/2021 - 18:53

Im having the same proplem, imported my previous works from 7.11.3 and now my project is unusable. Even the right click takes at least 5 seconds to react, if it reacts and doesnt freeze the studio. Building and deploying also takes forever.

We are about to migrate some live apps but as it is we cant do support with this studio. It took my whole day figuring out the problem.

If i have 1-2 veeeery simple proc files everything works, not as fast at 7.11, but it works at least, however after i import a bigger proc file my laptop goes helicopter and everything slowes down.

Im using windows 10 pro btw.

Edit: I tried importing my 7.9 project also on my pc, also windows 10 pro. My pc is a mid range gaming pc with ryzen 5 5600x and still cant use the studio because of this issue. I can play games at 60fps rtx on but cant run Bonita :)


Submitted by bruno.bouchon_1... on Thu, 02/11/2021 - 18:38

I'm having this problem too on Windows 10 pro. In my case, I noticed that it appears after I open the page/form/layout section. I learned to work on the forms through ui studio but I have to deploy the process each time rather than deploy the form.


Submitted by brt6178_1422639 on Thu, 02/11/2021 - 19:16


I'm on windows 10 too.

Bruno's message gave me an idea, so I just made the following test :

1) I open the Studio, click on diagrams and open a process. I try to open the initialization script of a business data and modify it : it works perfectly well with a fast response time.

2) I click on "Pages/Forms/Layouts" in "my project" exploring tree, to show all the forms and pages of my project, without opening any page or form. I try again to open a script window (the same as in step 1) : it goes very slowly !

3) I close the "Pages/Forms/Layouts" sub-tree, and try the same as before : it goes quickly !!

I tried many times the above test, and it always works the same way.

Hope that will help to solve the problem.

In the meanwhile, I will close the Pages subtree, before modifying a process.

Submitted by kurucsai.zoltan... on Thu, 02/11/2021 - 20:22


Thank you for the help, however in my case this does not work, i think maybe the project explorer cant handle the files? In my case i have about 20-30 proc files, and i cant deploy them without oppening the tree. Even right click action doesnt work most of the time.

And of course if i click on my current process tab the tree opens and everything is back to being slow :)

I think i will wait till this problem sorts out, i cant work with the studio like this.

I created 10 new proc files and played around with them, everything seems fine. Maybe it cant import my older version processes properly? Even with 2-3 of them it gets unusable. But i dont get it, why does my processes influence the gui response times? And overall speed of the gui actions?

Submitted by romain.bioteau on Fri, 02/12/2021 - 14:52

Hi! We have identified a cause for this performance regression and are currently testing fixes. Is it something possible for you to share your 7.11 bos file to help us reproduce your issue and validate the fix ?

Don't hesitate to use the bugtracker for this kind of feedbacks !

Submitted by brt6178_1422639 on Fri, 02/12/2021 - 17:08

Hello Romain,

since I don't know how to join a file here, I have created the BBPMC-591 ticket on bugtracker, with the bos file requested.It includes the last version of my processes in the 7.11.4 environment.