Trying to get the email connector to work



I am using the authentification i created with User1 // 123
I am using a test email i created
I have allowed unsecure through my gmail profile
I have unticked the SSL portion of the connector.

When i click Test, I get the following error:

org.bonitasoft.engine.bpm.connector.ConnectorExecutionException: USERNAME=install | org.bonitasoft.engine.core.connector.exception.SConnectorException: org.bonitasoft.engine.connector.exception.SConnectorException: java.util.concurrent.ExecutionException: org.bonitasoft.engine.connector.exception.SConnectorException: org.bonitasoft.engine.connector.ConnectorException: javax.mail.MessagingException: Could not connect to SMTP host:, port: 465, response: -1

I am confused as to why it says "USERNAME=install" since I have configured the username to be User1 and also used that user at the authentication step,

2 answers


Don't get misled, the install user you are seeing is the Bonita user that the "Test connector" feature uses to run the code of the Email connector, but it is not the user of the Gmail account, of course.
There does not seem to be anything wrong with your setup.
The cause of the error is more to look at the error cause returned by Gmail itself...
Have you tried running your code by executing you process from the studio, instead of clicking the "Test connector" feature button? If it works that way, we may have a problem specific with the "Test" button.
Thanks for your feedback,


Submitted by antoine.mottier on Mon, 05/06/2019 - 10:14

Additionally to Emmanuel comment I like to add that you need to configure your Google account to allow "Less secure app access" in order for Bonita email connector to be able to send email using GMail account. This can be done here:

Also you might want to share the full log file using for example Google Drive, Dropbox... it might includes more details about the root cause of the issue.


1.) Enable Less secure apps in your Gmail account .
2.) Disable antiviruses / Firewalls.