unable to resolve class com.company.model.XXX

1
0
-1

I'm trying the following 2 project samples.

  1. https://community.bonitasoft.com/project/expense-report-example
  2. https://community.bonitasoft.com/project/procurement-example

I succeeded in running these projects when I have only 1 project in Bonita Studio.

But when I import these 2 project samples, Bonita Studio shows "unable to resolve class com.company.model.XXX" error.

Project1 defines the following BDM objects

  • com.company.model.ExpenseReport
  • com.company.model.ExpenseReportLine

Project2 defines the following BDM objects

  • com.company.model.Supplier
  • com.company.model.Request
  • com.company.model.Quotation

(I think there is no conflict between these BDMs...)

When I delete BDM objects defined in the other project, the error will be resolved.

But I want to manage these 2 project at the same time.

I'd be very happy if someone could help me.

2 answers

1
+1
-1
This one is the BEST answer!

Thank you delphine,

I just leaved Bonita Studio for one night and today I found that the error has been resolved... (why?)...

To reproduce the issue, I deleted all processes and all BDM objects regarding these 2 projects and imported the project bos file again. Then, the issue reproduced.

Next, I restarted Bonita Studio. The proc files still showed error status. So I opened the proc file and click "refresh" button in "Validation status" tab. Then the error resolved.

I found that restarting Bonita Studio can be workaround for this kind of issue. Thank you for your support, delphine.

Comments

Submitted by delphine.coille... on Wed, 07/29/2020 - 09:52

I am happy you could finally resolve it.

1
0
-1

Hi yastan1104,

If you are using Bonita 7.10 or 7.11 you can define multiple packages in your BDM as explained in the documentation. This should avoid conflicts.

Comments

Submitted by yastan1104 on Tue, 07/28/2020 - 14:54

Thank you delphine,

I use Bonita Studio 7.10.5.

I have already tried the solution before and faced the same kind of issue.

In my understanding this issue is not caused by conflicts. Because object's names are unique.

Submitted by delphine.coille... on Tue, 07/28/2020 - 16:37

I've tried to reproduce but it works for me. Can you share the engine logs? And try to clean the database before deploying?

Notifications