7.4 Migration Tool getting Unsupported major.minor version error

1
0
-1

The hardware/software requirements for 7.4.1 indicate using either Java 7 or 8; however when I try to upgrade to 7.4.1 and run the migration tool using Java 7, I get the below error, which indicates that I need Java 8. Is that correct? That I should really be using Java 8 for 7.4.1?

Exception in thread "main" java.lang.UnsupportedClassVersionError: org/bonitasoft/migration/core/Migration : Unsupported major.minor version 52.0
**

1 answer

1
0
-1

For Tomcat Bundle 7 is OK,

But if using WildFly then 8 is an absolute must. It will not run on 7.

Documentation should be updated to reflect this...

regards
Seán

PS: As this reply answers your question, please mark as resolved.

Comments

Submitted by pearthal on Thu, 01/19/2017 - 21:25

Assuming the Migration Tool requires 8 to run. It is the Migration Tool that is getting the error.

Submitted by Sean McP on Fri, 01/20/2017 - 04:25

What Java do you have installed?

Submitted by pearthal on Fri, 01/20/2017 - 14:38

Currently on 1.7.0.65, but we are going to move to 8 anyway, so hoping that will solve the problem once that gets installed.

Notifications