How to solve java.lang.ClassNotFoundException: org.bonitasoft.console.common.server.sso.filter.InternalSSOFilter error in docker?


I tried to run bonita 7.11 in docker, but it doesnt start correctly, it worked fine with version 7.9.

I get the following error:

2020-08-11 08:37:39.658 +0000 SEVERE: org.apache.catalina.core.ContainerBase.[Catalina].[localhost].[/bonita] Exception starting filter [InternalSSOFilter]
bonita | java.lang.ClassNotFoundException: org.bonitasoft.console.common.server.sso.filter.InternalSSOFilter
bonita | at org.apache.catalina.loader.WebappClassLoaderBase.loadClass(
bonita | at org.apache.catalina.loader.WebappClassLoaderBase.loadClass(
bonita | at org.apache.catalina.core.DefaultInstanceManager.loadClass(
bonita | at org.apache.catalina.core.DefaultInstanceManager.loadClassMaybePrivileged(
bonita | at org.apache.catalina.core.DefaultInstanceManager.newInstance(
bonita | at org.apache.catalina.core.ApplicationFilterConfig.getFilter(
bonita | at org.apache.catalina.core.ApplicationFilterConfig.(
bonita | at org.apache.catalina.core.StandardContext.filterStart(
bonita | at org.apache.catalina.core.StandardContext.startInternal(
bonita | at org.apache.catalina.util.LifecycleBase.start(
bonita | at org.apache.catalina.core.ContainerBase.addChildInternal(
bonita | at org.apache.catalina.core.ContainerBase.addChild(
bonita | at org.apache.catalina.core.StandardHost.addChild(
bonita | at org.apache.catalina.startup.HostConfig.deployDescriptor(
bonita | at org.apache.catalina.startup.HostConfig$
bonita | at java.base/java.util.concurrent.Executors$
bonita | at java.base/
bonita | at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(
bonita | at java.base/java.util.concurrent.ThreadPoolExecutor$
bonita | at java.base/

What could cause this error? How can I fix it? (I get 404 error code when I try to acces the bonita portal.)

Best regards,


1 answer

This one is the BEST answer!

I solved the problem, by using the never version web.xml from github (7.11.1). I had to remove everything that uses sso.filter in that file.

I dont know if it is on purpose or I did something wrong, but the persistence id is no longer autoincrement after the creation of the businessdb, but this is will be a new question.