Setting up Exlcusive Gateway


Hi Newbie on Bonita here. I am trying to get a exclusive gateway set up but can't figure it out. The first gateway Has the flow defaulting on the Yes track and it's giving me the message at the bottom of the screen. How do I resolve this? Screenshot here


1 answer


If the default Flow is "Yes", then you have to select the flow named "No", then click on the General tab and select the condition "Use the expression" and then click on the pencil icon to the right of that option and write a Groovy script which should return a boolean value, for example:

 if (employeeAge >= 18) {
    return true
} else {
    return false

Anyway I attach the link to a sample project that makes use of the XOR gateways, just download the .bos file and import it into your Bonita Studio.


Submitted by delphine.coille on Thu, 05/06/2021 - 09:26

An in addition to alexjhcm_2529035 answer, don't forget to select the other transition (Yes) as default by clicking the checkbox as shown here:

. .

It seems that this default flow is missing in your process screenshot.